macd金叉的选股公式

编写一个通达信选股公式,MACD周线金叉

选股公式如下,选股周期选择周线,

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

XG:BARSLAST(CROSS(DIF,DEA))>0 AND DIF>DEA;

MACD金叉选股公式怎么看?

MACD称为指数平滑异同平均线,是从双指数移动平均线发展而来的,由快的指数移动平均线(EMA)减去慢的指数移动平均线,MACD的意义和双移动平均线基本相同,但阅读起来更方便。当MACD从负数转向正数,是买的信号。当MACD从正数转向负数,是卖的信号。当MACD以大角度变化,表示快的移动平均线和慢的移动平均线的差距非常迅速的拉开,代表了一个市场大趋势的转变。详细看视频讲解@~!

请高手帮忙写一个MACD金叉并且平行向上的选股公式(不含未来),谢谢!

{对“平行向上”--的理解,见下面的表达:}

XG:BARSLAST(CROSS(MACD.DIF,MACD.DEA))<=10 AND  ABS(MACD.DIF-MACD.DEA)/MAX(MACD.DIF,MACD.DEA)>=0.1 AND ABS(MACD.DIF-MACD.DEA)/MAX(MACD.DIF,MACD.DEA)<0.5 AND MACD.DIF>MACD.DEA;

===================================

{MACD 必须是在0轴以下金叉。}

XG:BARSLAST(CROSS(MACD.DIF,MACD.DEA))<=10 AND  ABS(MACD.DIF-MACD.DEA)/MAX(MACD.DIF,MACD.DEA)<-0.1 AND ABS(MACD.DIF-MACD.DEA)/MAX(MACD.DIF,MACD.DEA)>-0.5 AND MACD.DIF>MACD.DEA AND MACD.DIF<0 AND MACD.DEA<0 ;

求macd 0轴上下附近金叉的选股公式

A:=CROSS(MACD.DIF,MACD.DEA);
A AND MACD.DIF>=MACD.DEA+0.01 AND RANGE(MACD.DIF,-0.3,0.3);

测试通过!希望能够帮助你!

关于通达信macd公式

2天后出现一根更长的线怎么办?macd经常出现此类现象,你这想法是无意义的。
看这类的请求太多了,觉得没必要的公式,太累了~

求通达信的选股公式,条件是MACD大于零。

{通达信中到目前为止系统还不支持60分钟、30分钟的选股平台,只能给你MACD日线选股。}
DIF:=EMA(C,12)-EMA(C,26);
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
MACD>0;
{上面的选股是你要的日线MACD大于0的选股公式,这一公式选出的股票一般都有一段涨幅了,我猜想你可能是要DIF红线上穿DEA黄线的选股吧。所以我帮你做了下面另一个公式}
DIF:=EMA(C,12)-EMA(C,26);
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
CROSS(DIF,DEA);