无未来函数超准指标,下面是一个通达信指标公式,太准了,肯定有未来函数。请高手去掉未来函数

内容导航:
  • 下面是一个通达信指标公式,太准了,肯定有未来函数。请高手去掉未来函数
  • 求一个通达信的在牛市里面很准的无未来函数的短线买点指标
  • 通达信分笔指标,比较准确,不含未来函数,怎么做到的
  • 哪位大哥能分享下无未来函数、无漂移的炒股高成功率的公式指标呀?!
  • 图片中副图指标:趋势吸筹的通达信源码请高手告知
  • 通信达公式问题,超强组合指标公式,谁可以解释一下。我看不明白,源代码如下
  • Q1:下面是一个通达信指标公式,太准了,肯定有未来函数。请高手去掉未来函数

    B:ZIG(3,50/5)*100,COLORWHITE;
    ZIG为未来函数.

    不能去掉。未来函数是这种公式的灵魂。

    Q2:求一个通达信的在牛市里面很准的无未来函数的短线买点指标

    {ok.奉献一个很准的无未来函数的短线买点指标给楼主}
    O1:(SUM(EMA((CLOSE+LOW)/2,1)/3,3)),COLOR00FFFF,LINETHICK1;
    O2:EMA(O1,3),COLORFF00FF,LINETHICK1;
    O3:EMA(O2,3),COLOR00FF00,LINETHICK1;
    AAA:=CROSS(O1,O2) AND CROSS(O2,O3) AND CROSS(O1,O3),LINETHICK1;
    DRAWICON(AAA,O1*0.95,17);
    MMM:=MA(CLOSE,20);
    PEAK1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
    VAR2:=REF(PEAK1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
    VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
    VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND PEAK1;
    VAR1A:=REF(PEAK1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
    VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
    STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.2,0),COLORFF3300;
    STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.7,0),COLORFF5500;
    STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.1,0),COLORFF7700;
    STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1.5,0),COLORFF9900;
    STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.9,0),COLORFFBB00;
    STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.3,0),COLORFFDD00;
    DRAWICON(FILTER(VAR19=1,5),LOW*0.995,9);{通达信只要把最后的数字8改成自己喜欢的图形对应的数字}
    DRAWICON(FILTER(VAR1A=1,5),HIGH*1.008,0);{通达信只要把最后的数字5改成自己喜欢的图形对应的数字}
    DRAWICON(FILTER(VAR1A=1,5),HIGH*1.03,15);{通达信只要把最后的数字3改成自己喜欢的图形对应的数字};

    Q3:通达信分笔指标,比较准确,不含未来函数,怎么做到的

    个人认为,缠论的分笔指标,如果一定要用公式表达,使用未来函数是不可避免的,主要使用zig,以及PEAKBARS(峰顶),TROUGHBARS(峰谷)指标。
    对于缠论,没必要太在意所畏的背驰,关键是它所描述的时间分级别、线段趋势打断这才是关键。如果是下跌趋势,即使是30分钟背驰,如果没有出现线段方向打断,后面还会有小时级别的背驰,之后还会出现日线级别背,如果这个过程你不幸持仓了,那损失可畏不少。缠论对操作的细节讲得比较模糊,抛出一大堆概念,每个人理解角度不同,会有不同的操作。缠只告诉我K线最基本走势是“之”字形。
    我认为炒股并没有缠所描述这么复杂,多看K线,把现有常用的统计指标和未来函数指理解透,自己动手编写属于自己的指标,你会更深入体会K线的性质,未来函数只起到定位的作用,操作还是要看传统统计函数。
    希望能帮到你~!

    Q4:哪位大哥能分享下无未来函数、无漂移的炒股高成功率的公式指标呀?!

    KDJ_K:="KDJ.K"(9,3,3);KDJ_D:="KDJ.D"(9,3,3);KDJ_J:="KDJ.J"(9,3,3);
    买1:=CROSS(KDJ_J,0) OR (CROSS(KDJ_J,KDJ_K) AND KDJ_D<26);
    买2:=CROSS("RSI.RSI1"(6,2,2),20) OR CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
    买3:=CROSS("MACD.DIF","MACD.DEA") OR CROSS("MACD.MACD",0);
    XG:买1 AND 买2 AND 买3;
    这是结合MACD,KDJ,和RSI三项买入条件的买入条件,应该说比较准,但是还是要关注大盘,大盘不好,指标再炫,一样没用的

    Q5:图片中副图指标:趋势吸筹的通达信源码请高手告知

    没见过这个指标,貌似两条均线之类的东西!要晓得思路倒是可以为你定做一个。

    Q6:通信达公式问题,超强组合指标公式,谁可以解释一下。我看不明白,源代码如下

    {波段线}
    VAR2:=(HIGH+LOW+CLOSE*2)/4;
    VAR3:=EMA(VAR2,21);
    VAR4:=STD(VAR2,21);
    VAR5:=((VAR2-VAR3)/VAR4*100+200)/4;
    VAR6:=(EMA(VAR5,5)-25)*1.56;
    {AK: EMA(VAR6,2)*1.22;
    AD1: EMA(AK,2);
    AJ: 3*AK-2*AD1;
    DRAWTEXT(CROSS(AK,AD1),AK,'*'),COLORRED;
    DRAWTEXT(CROSS(AD1,AK),AK,'*'),COLORWHITE;}
    {金手指}
    RA:=LLV(LOW,35);
    RB:=HHV(HIGH,30);
    RC:=EMA((CLOSE-RA)/(RB-RA)*4,4)*19;
    近日均价:=MA(CLOSE,5),COLORYELLOW,LINETHICK2;
    DRAWICON(RC<6 AND 100*(HHV(HIGH,19)-CLOSE)/(HHV(HIGH,19)-LLV(LOW,19))>97,100,11);
    LC:=REF(CLOSE,1);
    RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
    ZL:=EMA( (CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2)*5;
    SH:=EMA( (CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7)*5;
    BT1:=CROSS(RSI1,25);
    BT2:=CROSS(ZL,SH) AND ZL<-10;
    BT:=FILTER(COUNT(BT1 OR BT2,3)>=2,3);
    BIAS:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
    VARC:=LOW;
    VARD:=REF(LOW,1);
    VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),3,1)*100;
    VARF:=MA(VARE/10,3);
    VAR10:=LLV(LOW,30);
    VAR11:=HHV(VARF,30);
    MA(IF(LOW<=VAR10,(VARF+VAR11*2)/5,0),3);
    VAR1B:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
    VAR2B:=SMA(ABS(LOW-VAR1B),13,1)/SMA(MAX(LOW-VAR1B,0),10,1);
    VAR3B:=EMA(VAR2B,10);
    VAR4B:=LLV(LOW,33);
    VAR5B:=EMA(IF(LOW<=VAR4B,VAR3B,0),3);
    {主力进场:IF(VAR5B>REF(VAR5B,1),VAR5B,0),COLORRED;}
    STICKLINE(VAR5B>REF(VAR5B,1),0,VAR5B*2,2,0 ),COLORYELLOW;
    洗盘:IF(VAR5B<REF(VAR5B,1),VAR5B,0),COLORLIGREEN;
    VARR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
    VARR2:=SMA(ABS(LOW-VARR1),13,1)/SMA(MAX(LOW-VARR1,0),10,1);
    VARR3:=EMA(VARR2,10);
    VARR4:=LLV(LOW,33);
    VARR5:=EMA(IF(LOW<=VARR4,VARR3,0),3);
    STICKLINE(VARR5>REF(VARR5,1),0,VARR5,2,0 ),COLORGREEN;
    STICKLINE(VARR5<REF(VARR5,1),0,VARR5*2,2,0),COLORRED;
    找主力吸筹提款:VARR5>REF(VARR5,4) {AND C>REF(C,1)},COLORMAGENTA;
    VAR2C:=(HIGH+LOW+CLOSE*2)/4;
    VAR3C:=EMA(VAR2C,7);
    VAR4C:=STD(VAR2C,7);
    VAR5C:=(VAR2C-VAR3C)*100/VAR4;
    VAR6C:=EMA(VAR5C,3);
    {WW:(EMA(VAR6C,5)+100)/2-3,COLORFF00FF;
    MM:HHV(WW,3),COLORFF3333;}
    AAA:=AMOUNT/VOL/100;
    主力进场:IF(VAR5B>REF(VAR5B,1),VAR5B*1.5,0),COLORRED,LINETHICK2;
    {吸筹}
    VAR2Q:=REF(LOW,1);
    VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
    VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
    VAR5Q:=LLV(LOW,30);
    VAR6Q:=HHV(VAR4Q,30);
    VAR7Q:=IF(MA(CLOSE,58),1,0);
    VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/618*VAR7Q;
    VAR9Q:=IF(VAR8Q>100,100,VAR8Q);
    吸筹:STICKLINE(VAR9Q>-120,0,VAR9Q,6,1),COLORRED;
    VARY2:=REF(LOW,1);
    VARY3:=SMA(ABS(LOW-VARY2),3,1)/SMA(MAX(LOW-VARY2,0),3,1)*100;
    VARY4:=EMA(IF(CLOSE*1.3,VARY3*10,VARY3/10),3);
    VARY5:=LLV(LOW,30);
    VARY6:=HHV(VARY4,30);
    VARY7:=IF(MA(CLOSE,58),1,0);
    VARY8:=EMA(IF(LOW<=VARY5,(VARY4+VARY6*2)/2,0),3)/618*VARY7;
    VARY9:=IF(VARY8>100,100,VARY8);
    吸筹2:STICKLINE(VARY9>-120,0,VARY9/3,2,1),COLORMAGENTA;
    LCC:=REF(CLOSE,1);
    RSI:=SMA(MAX(CLOSE-LCC,0),4.1,1)/SMA(ABS(CLOSE-LCC),4.1,1)*100,COLORYELLOW,LINETHICK1;
    黄买:FILTER((REF(CLOSE,2)<CLOSE AND RSI<25),7),COLORYELLOW;
    STICKLINE(黄买,0,-40,10,1),COLORYELLOW;
    黄卖:=FILTER((REF(CLOSE,2)>CLOSE AND RSI>80),7);
    STICKLINE(黄卖,100,82,10,0),COLORBLUE;
    红买:FILTER(CROSS(RSI,11),7),COLORRED;
    STICKLINE(红买,0,-30,6,0),COLORRED;
    红卖:=FILTER(CROSS(89,RSI),7);
    STICKLINE(红卖,100,88,8,0),COLORCYAN;
    绿买:FILTER(CROSS(RSI,20),7),COLOR00FF00;
    STICKLINE(绿买,0,-20,6,0),COLORMAGENTA;
    绿卖:=FILTER(CROSS(80,RSI),7);
    STICKLINE(绿卖,100,94,6,0),COLOR00FF00;
    ★遵守纪律★:100,COLORRED;
    ★交易之魂★:100,COLORRED;
    ZLC:= EMA((WINNER(CLOSE) * 70),3);
    SHC:= EMA(((WINNER((CLOSE * 1.1)) - WINNER((CLOSE * 0.9))) * 80),3);
    主力控盘: ((ZLC / (ZLC+ SHC)) * 100),COLOR00FFFF,LINETHICK2;
    上限: HHV(主力控盘,20),COLORGREEN,LINETHICK2;
    下限: LLV(主力控盘,20),COLORRED,LINETHICK2;
    中线:(上限 + 下限)/2,COLORYELLOW,POINTDOT,LINETHICK2;
    {60,LINETHICK4,POINTDOT,COLORYELLOW;}
    {10,LINETHICK4,POINTDOT,COLORFF00FF;}
    VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
    VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
    VAR400:=EMA(VAR300,5);
    操盘:=3*VAR300-2*VAR400;
    A1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;
    STICKLINE(A1,30,0,4,0),COLOR770077;
    STICKLINE(A1,30,0,3,0),COLOR990099;
    STICKLINE(A1,30,0,2,0),COLORBB00BB;
    STICKLINE(A1,30,0,1,0),COLORWHITE;
    STICKLINE(A1,30,0,0.3,0),COLORFF00FF;
    DRAWTEXT(A1,36,'满仓'),COLORRED;
    DRAWTEXT(A1,36,'满仓'),COLORRED;
    AK: EMA(VAR6,2)*1.22;
    AD1: EMA(AK,2);
    AJ: 3*AK-2*AD1;
    DRAWTEXT(CROSS(AK,AD1),AK,'*'),COLORRED;
    DRAWTEXT(CROSS(AD1,AK),AK,'*'),COLORWHITE;
    WW:(EMA(VAR6C,5)+100)/2-3,COLORFF00FF;
    MM:HHV(WW,3),COLORFF3333;
    DRAWTEXT(BT1,0,'□'),COLORYELLOW;
    DRAWTEXT(BT,0,'■'),COLORYELLOW;
    DRAWICON(CROSS(85,RSI1),102,15);{饭跑跑}
    DRAWICON(CROSS(RSI1,25),10,26);{金钻}
    DRAWICON(CROSS(ZL,SH) AND ZL<-10,20,24);{蓝钻}
    DRAWICON(CROSS(BIAS,-12),-10,13);{BIAS买点};

    上一篇:上一篇:通达信日线怎么设置
    下一篇:下一篇:戴帽当天有涨的股票
    • 评论列表

    发表评论: